<!DOCTYPE html><!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
    <head>
        <meta charset="UTF-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge">
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <title>School board passes 2021-2022 compensation plan &#8211; San Benito News</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//maps.google.com' />
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//platform.linkedin.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="San Benito News &raquo; Feed" href="https://www.sbnewspaper.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="San Benito News &raquo; Comments Feed" href="https://www.sbnewspaper.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="San Benito News &raquo; School board passes 2021-2022 compensation plan Comments Feed" href="https://www.sbnewspaper.com/2021/06/17/school-board-passes-2021-2022-compensation-plan/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sbnewspaper.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='A5-framework-css'  href='https://www.sbnewspaper.com/a5-framework-frontend.css?ver=1.0%20beta%2020160127%20FCW' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.sbnewspaper.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='super-rss-reader-css'  href='https://www.sbnewspaper.com/wp-content/plugins/super-rss-reader/public/css/style.min.css?ver=4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://www.sbnewspaper.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.6' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.sbnewspaper.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='bootstrap-css'  href='https://www.sbnewspaper.com/wp-content/themes/graphene/bootstrap/css/bootstrap.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.sbnewspaper.com/wp-content/themes/graphene/fonts/font-awesome/css/font-awesome.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='graphene-css'  href='https://www.sbnewspaper.com/wp-content/themes/graphene/style.css?ver=2.7.5' type='text/css' media='screen' />
<link rel='stylesheet' id='graphene-responsive-css'  href='https://www.sbnewspaper.com/wp-content/themes/graphene/responsive.css?ver=2.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='graphene-print-css'  href='https://www.sbnewspaper.com/wp-content/themes/graphene/style-print.css?ver=2.7.5' type='text/css' media='print' />
<link rel='stylesheet' id='graphene-blocks-css'  href='https://www.sbnewspaper.com/wp-content/themes/graphene/blocks.css?ver=2.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://www.sbnewspaper.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=9.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.sbnewspaper.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.8.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/plugins/message-ticker/message-ticker.js?ver=5.7.2' id='message-ticker-js'></script>
<script type='text/javascript' src='https://maps.google.com/maps/api/js?sensor=false&#038;ver=5.7.2' id='googlemaps-js'></script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/plugins/itro-popup/scripts/itro-scripts.js?ver=5.7.2' id='itro-scripts-js'></script>
<script type='text/javascript' src='https://apis.google.com/js/plusone.js?ver=5.7.2' id='plusone-js'></script>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=5.7.2' id='twitter-js'></script>
<script type='text/javascript' src='https://platform.linkedin.com/in.js?ver=5.7.2' id='linkedin-js'></script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/plugins/super-rss-reader/public/js/jquery.easy-ticker.min.js?ver=4.2' id='jquery-easy-ticker-js'></script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/plugins/super-rss-reader/public/js/script.min.js?ver=4.2' id='super-rss-reader-js'></script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/themes/graphene/bootstrap/js/bootstrap.min.js?ver=2.7.5' id='bootstrap-js'></script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/themes/graphene/js/bootstrap-hover-dropdown/bootstrap-hover-dropdown.min.js?ver=2.7.5' id='bootstrap-hover-dropdown-js'></script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/themes/graphene/js/bootstrap-submenu/bootstrap-submenu.min.js?ver=2.7.5' id='bootstrap-submenu-js'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/themes/graphene/js/html5shiv/html5shiv.min.js?ver=2.7.5' id='html5shiv-js'></script>
<![endif]-->
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/themes/graphene/js/respond.js/respond.min.js?ver=2.7.5' id='respond-js'></script>
<![endif]-->
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/themes/graphene/js/jquery.infinitescroll.min.js?ver=2.7.5' id='infinite-scroll-js'></script>
<script type='text/javascript' id='graphene-js-extra'>
/* <![CDATA[ */
var grapheneJS = {"siteurl":"https:\/\/www.sbnewspaper.com","ajaxurl":"https:\/\/www.sbnewspaper.com\/wp-admin\/admin-ajax.php","templateUrl":"https:\/\/www.sbnewspaper.com\/wp-content\/themes\/graphene","isSingular":"1","enableStickyMenu":"","shouldShowComments":"1","commentsOrder":"newest","sliderDisable":"","sliderInterval":"6000","infScrollBtnLbl":"Load more","infScrollOn":"","infScrollCommentsOn":"","totalPosts":"1","postsPerPage":"10","isPageNavi":"","infScrollMsgText":"Fetching window.grapheneInfScrollItemsPerPage of window.grapheneInfScrollItemsLeft items left ...","infScrollMsgTextPlural":"Fetching window.grapheneInfScrollItemsPerPage of window.grapheneInfScrollItemsLeft items left ...","infScrollFinishedText":"All loaded!","commentsPerPage":"50","totalComments":"0","infScrollCommentsMsg":"Fetching window.grapheneInfScrollCommentsPerPage of window.grapheneInfScrollCommentsLeft comments left ...","infScrollCommentsMsgPlural":"Fetching window.grapheneInfScrollCommentsPerPage of window.grapheneInfScrollCommentsLeft comments left ...","infScrollCommentsFinishedMsg":"All comments loaded!","disableLiveSearch":"1","txtNoResult":"No result found.","isMasonry":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/themes/graphene/js/graphene.js?ver=2.7.5' id='graphene-js'></script>
<link rel="https://api.w.org/" href="https://www.sbnewspaper.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.sbnewspaper.com/wp-json/wp/v2/posts/168875" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sbnewspaper.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sbnewspaper.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel="canonical" href="https://www.sbnewspaper.com/2021/06/17/school-board-passes-2021-2022-compensation-plan/" />
<link rel='shortlink' href='https://wp.me/p3f7z7-HVN' />
<link rel="alternate" type="application/json+oembed" href="https://www.sbnewspaper.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sbnewspaper.com%2F2021%2F06%2F17%2Fschool-board-passes-2021-2022-compensation-plan%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sbnewspaper.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sbnewspaper.com%2F2021%2F06%2F17%2Fschool-board-passes-2021-2022-compensation-plan%2F&#038;format=xml" />
<link rel="stylesheet" type="text/css" href="https://www.sbnewspaper.com/wp-content/plugins/simple-likebuttons/simple_likebuttons.css" />
<link type="text/css" rel="stylesheet" href="https://www.sbnewspaper.com/wp-content/plugins/simple-pull-quote/css/simple-pull-quote.css" />
      <!-- WP bannerize Custom CSS -->
      <style type="text/css">
				</style>
      <!-- WP bannerize Custom CSS -->
    <!-- WordPress Most Popular --><script type="text/javascript">/* <![CDATA[ */ jQuery.post("https://www.sbnewspaper.com/wp-admin/admin-ajax.php", { action: "wmp_update", id: 168875, token: "82cd30a009" }); /* ]]> */</script><!-- /WordPress Most Popular -->		<script>
		   WebFontConfig = {
		      google: { 
		      	families: ["Lato:400,400i,700,700i&display=swap"]		      }
		   };

		   (function(d) {
		      var wf = d.createElement('script'), s = d.scripts[0];
		      wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js';
		      wf.async = true;
		      s.parentNode.insertBefore(wf, s);
		   })(document);
		</script>
	<style type="text/css">
#top-bar{background-color:#ffffff}.sidebar .sidebar-wrap {background-color: #ededed; border-color: #dbdbdb}.post-nav-top, .archive-title, .page-title, .term-desc, .breadcrumb {background-color: #9f80c6; border-color: #6b3589}body{background-image:none}.header_title, .header_title a, .header_title a:visited, .header_title a:hover, .header_desc {color:#blank}.carousel, .carousel .item{height:400px}@media (max-width: 991px) {.carousel, .carousel .item{height:250px}}#header{max-height:198px}
</style>
		<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","mainEntityOfPage":"https:\/\/www.sbnewspaper.com\/2021\/06\/17\/school-board-passes-2021-2022-compensation-plan\/","publisher":{"@type":"Organization","name":"San Benito News","logo":{"@type":"ImageObject","url":"https:\/\/www.sbnewspaper.com\/wp-content\/uploads\/2016\/10\/cropped-SBN-LOGO-2016-THUMBNAIL-1-32x32.gif","height":32,"width":32}},"headline":"School board passes 2021-2022 compensation plan","datePublished":"2021-06-17T14:53:24+00:00","dateModified":"2021-06-17T14:58:03+00:00","description":"<div class=\"sharedaddy sd-sharing-enabled\"><div class=\"robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing\"><h3 class=\"sd-title\">Share this:<\/h3><div class=\"sd-content\"><ul><li><a href=\"#\" class=\"sharing-anchor sd-button share-more\"><span>Share<\/span><\/a><\/li><li class=\"share-end\"><\/li><\/ul><div class=\"sharing-hidden\"><div class=\"inner\" style=\"display: none;\"><ul><li class=\"share-facebook\"><a rel=\"nofollow noopener noreferrer\" data-shared=\"sharing-facebook-168875\" class=\"share-facebook sd-button share-icon\" href=\"https:\/\/www.sbnewspaper.com\/2021\/06\/17\/school-board-passes-2021-2022-compensation-plan\/?share=facebook\" target=\"_blank\" title=\"Click to share on Facebook\"><span>Facebook<\/span><\/a><\/li><li class=\"share-email\"><a rel=\"nofollow noopener noreferrer\" data-shared=\"\" class=\"share-email sd-button share-icon\" href=\"https:\/\/www.sbnewspaper.com\/2021\/06\/17\/school-board-passes-2021-2022-compensation-plan\/?share=email\" target=\"_blank\" title=\"Click to email this to a friend\"><span>Email<\/span><\/a><\/li><li class=\"share-end\"><\/li><li class=\"share-print\"><a rel=\"nofollow noopener noreferrer\" data-shared=\"\" class=\"share-print sd-button share-icon\" href=\"https:\/\/www.sbnewspaper.com\/2021\/06\/17\/school-board-passes-2021-2022-compensation-plan\/#print\" target=\"_blank\" title=\"Click to print\"><span>Print<\/span><\/a><\/li><li class=\"share-end\"><\/li><\/ul><\/div><\/div><\/div><\/div><\/div>","author":{"@type":"Person","name":"Editor"},"image":["https:\/\/www.sbnewspaper.com\/wp-content\/uploads\/2019\/02\/2019-sbcisd-logo-e1571431572545.jpg"]}</script>
	<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #f2f2f2; }
</style>
	
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="School board passes 2021-2022 compensation plan" />
<meta property="og:url" content="https://www.sbnewspaper.com/2021/06/17/school-board-passes-2021-2022-compensation-plan/" />
<meta property="og:description" content="By LOUIE DIAZ editor@sbnewspaper.com The San Benito Board of Trustees made amendments to and passed the proposed 2021-2022 compensation plan during a board meeting on June 8. Trustee Rudy Corona as…" />
<meta property="article:published_time" content="2021-06-17T19:53:24+00:00" />
<meta property="article:modified_time" content="2021-06-17T19:58:03+00:00" />
<meta property="og:site_name" content="San Benito News" />
<meta property="og:image" content="https://www.sbnewspaper.com/wp-content/uploads/2016/10/cropped-SBN-LOGO-2016-THUMBNAIL-1.gif" />
<meta property="og:image:width" content="512" />
<meta property="og:image:height" content="512" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="School board passes 2021-2022 compensation plan" />
<meta name="twitter:image" content="https://www.sbnewspaper.com/wp-content/uploads/2016/10/cropped-SBN-LOGO-2016-THUMBNAIL-1-270x270.gif" />
<meta name="twitter:card" content="summary" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://www.sbnewspaper.com/wp-content/uploads/2016/10/cropped-SBN-LOGO-2016-THUMBNAIL-1-32x32.gif" sizes="32x32" />
<link rel="icon" href="https://www.sbnewspaper.com/wp-content/uploads/2016/10/cropped-SBN-LOGO-2016-THUMBNAIL-1-192x192.gif" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.sbnewspaper.com/wp-content/uploads/2016/10/cropped-SBN-LOGO-2016-THUMBNAIL-1-180x180.gif" />
<meta name="msapplication-TileImage" content="https://www.sbnewspaper.com/wp-content/uploads/2016/10/cropped-SBN-LOGO-2016-THUMBNAIL-1-270x270.gif" />
			<style type="text/css" id="wp-custom-css">
				.alignright {
    float:right;
    margin: 5px 0 20px 20px;
}			</style>
		    <!-- BEGIN Google Analytics script -->
    	<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-18801614-6']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>    <!-- END Google Analytics script -->
        </head>
    <body class="post-template-default single single-post postid-168875 single-format-standard custom-background wp-embed-responsive layout-boxed two_col_left two-columns singular">
        
        <div class="container boxed-wrapper">
            
                            <div id="top-bar" class="row clearfix light">
                                            <div class="col-md-12 top-bar-items">
                            
                                                                                        	<ul class="social-profiles">
							
			            <li class="social-profile social-profile-rss">
			            	<a href="https://www.sbnewspaper.com/feed/" title="Subscribe to San Benito News&#039;s RSS feed" id="social-id-1" class="mysocial social-rss" target="_blank">
			            				                            <i class="fa fa-rss"></i>
		                        			            	</a>
			            </li>
		            
		    						
			            <li class="social-profile social-profile-twitter">
			            	<a href="http://twitter.com/sanbenitonews" title="Follow Us On Twitter" id="social-id-2" class="mysocial social-twitter" target="_blank">
			            				                            <i class="fa fa-twitter"></i>
		                        			            	</a>
			            </li>
		            
		    						
			            <li class="social-profile social-profile-facebook">
			            	<a href="http://www.facebook.com/pages/San-Benito-News/138794999525117?ref=hl" title="Like Us On Facebook" id="social-id-3" class="mysocial social-facebook" target="_blank">
			            				                            <i class="fa fa-facebook"></i>
		                        			            	</a>
			            </li>
		            
		    	    </ul>
                                
                                                            <button type="button" class="search-toggle navbar-toggle collapsed" data-toggle="collapse" data-target="#top_search">
                                    <span class="sr-only">Toggle search form</span>
                                    <i class="fa fa-search-plus"></i>
                                </button>

                                <div id="top_search">
                                    <form class="searchform" method="get" action="https://www.sbnewspaper.com">
	<div class="input-group">
		<div class="form-group live-search-input">
		    <input type="text" name="s" class="form-control" placeholder="Search">
		    		</div>
	    <span class="input-group-btn">
	    	<button class="btn btn-default" type="submit"><i class="fa fa-search"></i></button>
	    </span>
    </div>
    </form>                                                                    </div>
                                                        
                                                    </div>
                                    </div>
            

            <div id="header" class="row">

                <img src="https://www.sbnewspaper.com/wp-content/uploads/2012/11/SBN-online-flag-revamped-copy.jpg" alt="San Benito News" title="San Benito News" width="960" height="198" />                
                                    <a href="https://www.sbnewspaper.com" id="header_img_link" title="Go back to the front page">&nbsp;</a>                            </div>


                        <nav class="navbar row ">

                <div class="navbar-header align-center">
                		                    <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#header-menu-wrap, #secondary-menu-wrap">
	                        <span class="sr-only">Toggle navigation</span>
	                        <span class="icon-bar"></span>
	                        <span class="icon-bar"></span>
	                        <span class="icon-bar"></span>
	                    </button>
                	                    
                    
                                            <p class="header_title mobile-only">
                            <a href="https://www.sbnewspaper.com" title="Go back to the front page">                                San Benito News                            </a>                        </p>
                    
                                            
                                    </div>

                                    <div class="collapse navbar-collapse" id="header-menu-wrap">

            			<ul id="header-menu" class="nav navbar-nav flip"><li id="menu-item-165" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-165"><a href="https://www.sbnewspaper.com">Home</a></li>
<li id="menu-item-161" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-161"><a href="https://www.sbnewspaper.com/category/news/">News</a></li>
<li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://www.sbnewspaper.com/category/sports/">Sports</a></li>
<li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-163"><a title="Opinion" href="https://www.sbnewspaper.com/category/opinion/" class="dropdown-toggle" data-toggle="dropdown" data-submenu="1" data-depth="10" data-hover="dropdown" data-delay="0">Opinion <i class="fa fa-chevron-down"></i></a>
<ul class="dropdown-menu">
	<li id="menu-item-2078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2078"><a href="https://www.sbnewspaper.com/category/opinion/letters/">Letters to the Editor</a></li>
	<li id="menu-item-2079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2079"><a href="https://www.sbnewspaper.com/category/opinion/staff-columns/">Staff Columns</a></li>
</ul>
</li>
<li id="menu-item-164" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164"><a href="https://www.sbnewspaper.com/category/gallery/">Gallery</a></li>
<li id="menu-item-186" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-186"><a href="https://www.sbnewspaper.com/?cat=11">Obituaries</a></li>
<li id="menu-item-158" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-158"><a title="E-Editions" href="http://www.etypeservices.com/San%20Benito%20NewsID78/" class="dropdown-toggle" data-toggle="dropdown" data-submenu="1" data-depth="10" data-hover="dropdown" data-delay="0">E-Editions <i class="fa fa-chevron-down"></i></a>
<ul class="dropdown-menu">
	<li id="menu-item-2209" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2209"><a href="http://www.etypeservices.com/San%20Benito%20NewsID78/Default.aspx">San Benito News</a></li>
	<li id="menu-item-2081" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2081"><a href="http://www.etypeservices.com/South%20Padre%20ParadeID401/">South Padre Parade</a></li>
	<li id="menu-item-3859" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3859"><a href="http://www.etypeservices.com/San%20Benito%20NewsID78/Default.aspx">RGV Football Preview</a></li>
	<li id="menu-item-250" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-250"><a href="http://www.etypeservices.com/San%20Benito%20NewsID78/Default.aspx">Winter Texan Guide</a></li>
</ul>
</li>
<li id="menu-item-9040" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9040"><a href="https://www.sbnewspaper.com/about/">Contact Us</a></li>
</ul>                        
            			                        
                                            </div>
                
                                    
                            </nav>

            
            <div id="content" class="clearfix hfeed row">
                
                    
                                        
                    <div id="content-main" class="clearfix content-main col-md-8">
                    
	
		<div class="post-nav post-nav-top clearfix">
			<p class="previous col-sm-6"><i class="fa fa-arrow-circle-left"></i> <a href="https://www.sbnewspaper.com/2021/06/17/sbhs-cross-country-and-track-coach-hosts-fundraiser-for-athlete/" rel="prev">SBHS cross country and track coach hosts fundraiser for athlete</a></p>			<p class="next-post col-sm-6"><a href="https://www.sbnewspaper.com/2021/06/17/city-commission-holds-first-budget-meeting-for-next-fiscal-year/" rel="next">City Commission holds first budget meeting for next fiscal year</a> <i class="fa fa-arrow-circle-right"></i></p>					</div>
		        
<div id="post-168875" class="clearfix post post-168875 type-post status-publish format-standard has-post-thumbnail hentry category-news item-wrap">
		
	<div class="entry clearfix">
    	
                    	<div class="post-date date alpha with-year">
            <p class="default_date">
            	<span class="month">Jun</span>
                <span class="day">17</span>
                	                <span class="year">2021</span>
                            </p>
                    </div>
            
		        <h1 class="post-title entry-title">
			School board passes 2021-2022 compensation plan			        </h1>
		
			    <ul class="post-meta">
	    		        <li class="byline">
	        	By <span class="author"><a href="https://www.sbnewspaper.com/author/editor/" rel="author">Editor</a></span> in <span class="terms"><a class="term term-category term-3" href="https://www.sbnewspaper.com/category/news/">News</a></span>	        </li>
	        	        <li class="print-date">
	        	<p class="printonly"><em>June 17, 2021</em></p>	        </li>
	        	        <li class="print">
	        	        <a href="javascript:print();" title="Print this post">
            <i class="fa fa-print"></i>
        </a>
    	        </li>
	        	    </ul>
    		
				<div class="entry-content clearfix">
							
										
						<p>By LOUIE DIAZ<br />
editor@sbnewspaper.com</p>
<p>The San Benito Board of Trustees made amendments to and passed the proposed 2021-2022 compensation plan during a board meeting on June 8.<br />
Trustee Rudy Corona asked if SBCISD employees could receive more than a 3% raise. The proposed plan had a 2% increase in employee pay across the board.<br />
Vicki Perez, assistant superintendent of finance and operations, recommended that a 3.5% increase would be the most feasible.<br />
“In my opinion, we should not go anything more than a percentage and a half, so 3.5% would be a conservative amount that we could sustain for the next two years,” Perez said.<br />
Board president, Ramiro Moreno, argued that a small percentage increase could make a difference.<br />
“When you compare the percentage increases between a salaried individual and an hourly individual, it makes quite a difference, so a 3% raise across the board for our salaried people and 4% for hourly seems pretty fair,” Moreno said.<br />
Trustee Dr. Ariel Cruz asked what consequences the district may face if they increase pay by too much.<br />
Dr. Andrea Cruz, the assistant superintendent of administrative services, answered that staff would have to be cut if the compensation plan gets too high.<br />
After some deliberation, the board settled with Perez’s recommendation of a 3.5% increase to both salary and hourly employees.<br />
Moreno had an issue with elementary level counselors and high school counselors being at a higher pay grade than department directors and suggested that the directors be at a higher pay grade.</p>
<p><em>Want the full story? Click <a href="https://www.etypeservices.com/San%20Benito%20NewsID78/Default.aspx" target="_blank" rel="noopener noreferrer">here</a> or grab a copy of the June 18, 2021 – June 24, 2021</em></p>
<div class="slideshow_container slideshow_container_style-light" data-slideshow-id="168865" data-style-name="style-light" data-style-version="2.3.1" data-slideshow-active="1">
<div class="slideshow_content">
<div class="slideshow_view">
	<div class="slideshow_container slideshow_container_style-light" style="height: 640px; " data-slideshow-id="168865" data-style-name="style-light" data-style-version="2.3.1" >

					<div class="slideshow_loading_icon"></div>
		
		<div class="slideshow_content" style="display: none;">

			<div class="slideshow_view">
				<div class="slideshow_slide slideshow_slide_image">
											<img src="https://www.sbnewspaper.com/wp-content/uploads/2021/06/VBMC-6x3-3-scaled.jpg" alt="VBMC 6x3" width="2048" height="622" />
										<div class="slideshow_description_box slideshow_transparent">
						<div class="slideshow_title">VBMC 6x3</div>											</div>
				</div>

						<div style="clear: both;"></div></div><div class="slideshow_view">
				<div class="slideshow_slide slideshow_slide_image">
											<img src="https://www.sbnewspaper.com/wp-content/uploads/2021/06/SBCISD-Child-Nutrition-Sites-6-4-21-6-18-21-4x7-1.jpg" alt="SBCISD (Child Nutrition Sites - 6-4-21; 6-18-21) 4x7" width="1978" height="2048" />
										<div class="slideshow_description_box slideshow_transparent">
						<div class="slideshow_title">SBCISD (Child Nutrition Sites - 6-4-21; 6-18-21) 4x7</div>											</div>
				</div>

						<div style="clear: both;"></div></div><div class="slideshow_view">
				<div class="slideshow_slide slideshow_slide_image">
											<img src="https://www.sbnewspaper.com/wp-content/uploads/2021/06/City-of-San-Benito-Request-For-Qualifications-6-11-21-3x5-2.jpg" alt="City of San Benito (Request For Qualifications - 6-11-21) 3x5" width="1626" height="1575" />
										<div class="slideshow_description_box slideshow_transparent">
						<div class="slideshow_title">City of San Benito (Request For Qualifications - 6-11-21) 3x5</div>											</div>
				</div>

						<div style="clear: both;"></div></div><div class="slideshow_view">
				<div class="slideshow_slide slideshow_slide_image">
											<img src="https://www.sbnewspaper.com/wp-content/uploads/2021/06/City-of-S.B-scaled.jpg" alt="City of S.B" width="1400" height="2048" />
										<div class="slideshow_description_box slideshow_transparent">
						<div class="slideshow_title">City of S.B</div>											</div>
				</div>

						<div style="clear: both;"></div></div>
		</div>

		<div class="slideshow_controlPanel slideshow_transparent" style="display: none;"><ul><li class="slideshow_togglePlay" data-play-text="Play" data-pause-text="Pause"></li></ul></div>

		<div class="slideshow_button slideshow_previous slideshow_transparent" role="button" data-previous-text="Previous" style="display: none;"></div>
		<div class="slideshow_button slideshow_next slideshow_transparent" role="button" data-next-text="Next" style="display: none;"></div>

		<div class="slideshow_pagination" style="display: none;" data-go-to-text="Go to slide"><div class="slideshow_pagination_center"></div></div>

		<!-- WordPress Slideshow Version 2.3.1 -->

			</div>

</div>
</div>
</div>
<div class="simple_likebuttons_container">
      <div class="simple_likebuttons_facebook">
        <div id="fb-root"></div>
        <script>(function(d, s, id) {
          var js, fjs = d.getElementsByTagName(s)[0];
          if (d.getElementById(id)) {return;}
          js = d.createElement(s); js.id = id;
          js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
          fjs.parentNode.insertBefore(js, fjs);
        }(document, "script", "facebook-jssdk"));</script>
        <div class="fb-like" data-href="https://www.sbnewspaper.com/2021/06/17/school-board-passes-2021-2022-compensation-plan/" data-send="false" data-layout="box_count" data-show-faces="false" data-width="55"></div>
      </div>
    
      <div class="simple_likebuttons_twitter">
        <a href="https://twitter.com/share" class="twitter-share-button" data-count="vertical" data-url="https://www.sbnewspaper.com/2021/06/17/school-board-passes-2021-2022-compensation-plan/" data-lang="en">Tweet</a>
      </div>
    
      <div class="simple_likebuttons_googleplus">
        <g:plusone size="tall" href="https://www.sbnewspaper.com/2021/06/17/school-board-passes-2021-2022-compensation-plan/"></g:plusone>
      </div>
    
      <div class="simple_likebuttons_linkedin">
        <script type="IN/Share" data-url="https://www.sbnewspaper.com/2021/06/17/school-board-passes-2021-2022-compensation-plan/" data-counter="top"></script>
      </div>
    
      <div class="simple_likebuttons_xing">
        <script data-url="https://www.sbnewspaper.com/2021/06/17/school-board-passes-2021-2022-compensation-plan/" data-lang="de" data-counter="top" type="XING/Share"></script>
        <script>
          ;(function(d, s) {
            var x = d.createElement(s),
              s = d.getElementsByTagName(s)[0];
            x.src ='https://www.xing-share.com/js/external/share.js';
            s.parentNode.insertBefore(x, s);
          })(document, 'script');
        </script>
      </div></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li><a href="#" class="sharing-anchor sd-button share-more"><span>Share</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-168875" class="share-facebook sd-button share-icon" href="https://www.sbnewspaper.com/2021/06/17/school-board-passes-2021-2022-compensation-plan/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://www.sbnewspaper.com/2021/06/17/school-board-passes-2021-2022-compensation-plan/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-end"></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://www.sbnewspaper.com/2021/06/17/school-board-passes-2021-2022-compensation-plan/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>								</div>
		
			    <ul class="entry-footer">
	    		        <li class="addthis col-sm-8"><div class="add-this"></div></li>
	        	    </ul>
    	</div>

</div>

    <div class="entry-author">
        <div class="row">
            <div class="author-avatar col-sm-3">
            	<a href="https://www.sbnewspaper.com/author/editor/" rel="author">
					<img alt='' src='https://secure.gravatar.com/avatar/70b8b7098e3f291b4907d36c0ca0481b?s=200&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/70b8b7098e3f291b4907d36c0ca0481b?s=400&#038;d=mm&#038;r=pg 2x' class='avatar avatar-200 photo' height='200' width='200' loading='lazy'/>                </a>
            </div>

            <div class="author-bio col-sm-9">
                <h3 class="section-title-sm">Editor</h3>
                    <ul class="author-social">
    	        
			        <li><a href="mailto:editor@sbnewspaper.com"><i class="fa fa-envelope-o"></i></a></li>
            </ul>
                </div>
        </div>
    </div>
    
<p class="printonly"><span class="printonly url"><strong>Permanent link to this article: </strong><span>https://www.sbnewspaper.com/2021/06/17/school-board-passes-2021-2022-compensation-plan/</span></span></p>











	<div id="comment-form-wrap" class="clearfix">
			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a class="btn btn-white btn-sm" rel="nofollow" id="cancel-comment-reply-link" href="/2021/06/17/school-board-passes-2021-2022-compensation-plan/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.sbnewspaper.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p  class="comment-notes">Your email address will not be published.</p><div class="form-group">
								<label for="comment" class="sr-only"></label>
								<textarea name="comment" class="form-control" id="comment" cols="40" rows="10" aria-required="true" placeholder="Your message"></textarea>
							</div><div class="row"><div class="form-group col-sm-4">
						<label for="author" class="sr-only"></label>
						<input type="text" class="form-control" aria-required="true" id="author" name="author" value="" placeholder="Name" />
					</div>
<div class="form-group col-sm-4">
						<label for="email" class="sr-only"></label>
						<input type="text" class="form-control" aria-required="true" id="email" name="email" value="" placeholder="Email" />
					</div>
<div class="form-group col-sm-4">
						<label for="url" class="sr-only"></label>
						<input type="text" class="form-control" id="url" name="url" value="" placeholder="Website (optional)" />
					</div>
</div><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='168875' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="9493c8bafb" /></p><div class="g-recaptcha" data-sitekey="6Ldl6_0SAAAAAImP9BiqoR7IYDGmI3oKGCF0egXb" data-theme="standard"></div><script type="text/javascript"src="https://www.google.com/recaptcha/api.js?hl=en"></script>            <div id="recaptcha-submit-btn-area">&nbsp;</div>
            <noscript>
            <style type='text/css'>#submit {display:none;}</style>
            <input name="submit" type="submit" id="submit-alt" tabindex="6"
                value="Submit Comment"/> 
            </noscript><input type="hidden" id="ak_js" name="ak_js" value="227"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea><div class="clear"></div></form>	</div><!-- #respond -->
		</div>
    

            
  

                </div><!-- #content-main -->
        
            
<div id="sidebar1" class="sidebar sidebar-right widget-area col-md-4">

	
    <div id="fbw_id-2" class="sidebar-wrap clearfix widget_fbw_id"><h3>Like Us On Facebook</h3><div class="fb_loader" style="text-align: center !important;"><img src="https://www.sbnewspaper.com/wp-content/plugins/facebook-pagelike-widget/loader.gif" alt="Facebook Pagelike Widget" /></div><div id="fb-root"></div>
        <div class="fb-page" data-href="https://www.facebook.com/SANBENITONEWS/ " data-width="250" data-height="350" data-small-header="false" data-adapt-container-width="false" data-hide-cover="false" data-show-facepile="true" data-show-posts="true" style="" hide_cta="false" data-tabs="timeline"></div></div>        <!-- A WordPress plugin developed by Milap Patel -->
    
		<div id="recent-posts-4" class="sidebar-wrap clearfix widget_recent_entries">
		<h3>Recent Posts</h3>
		<ul>
											<li>
					<a href="https://www.sbnewspaper.com/2021/06/17/defenestration-of-the-sb-city-charter/">Defenestration of the SB City Charter</a>
									</li>
											<li>
					<a href="https://www.sbnewspaper.com/2021/06/17/a-fathers-day-story-a-story-of-hope-young-cancer-survivor-pursues-hollywood-dream/">A Father’s Day Story – A Story of Hope Young cancer survivor pursues Hollywood dream</a>
									</li>
											<li>
					<a href="https://www.sbnewspaper.com/2021/06/17/hernandez-signs-with-bethany-college-to-play-football/">Hernandez signs with Bethany College to play football</a>
									</li>
											<li>
					<a href="https://www.sbnewspaper.com/2021/06/17/city-commission-holds-first-budget-meeting-for-next-fiscal-year/">City Commission holds first budget meeting for next fiscal year</a>
									</li>
											<li>
					<a href="https://www.sbnewspaper.com/2021/06/17/school-board-passes-2021-2022-compensation-plan/" aria-current="page">School board passes 2021-2022 compensation plan</a>
									</li>
											<li>
					<a href="https://www.sbnewspaper.com/2021/06/17/sbhs-cross-country-and-track-coach-hosts-fundraiser-for-athlete/">SBHS cross country and track coach hosts fundraiser for athlete</a>
									</li>
											<li>
					<a href="https://www.sbnewspaper.com/2021/06/10/attebery-wins-2021-sbn-scholarship/">Attebery wins 2021 SBN Scholarship</a>
									</li>
											<li>
					<a href="https://www.sbnewspaper.com/2021/06/10/students-project-highlights-sbs-black-community/">Student’s project highlights SB’s black community</a>
									</li>
											<li>
					<a href="https://www.sbnewspaper.com/2021/06/10/school-board-discusses-next-school-years-compensation-plan/">School board discusses next school year’s compensation plan</a>
									</li>
											<li>
					<a href="https://www.sbnewspaper.com/2021/06/10/city-distributes-sandbags-amid-hurricane-season/">City distributes sandbags amid hurricane season</a>
									</li>
					</ul>

		</div><div id="recent-comments-5" class="sidebar-wrap clearfix widget_recent_comments"><h3>Recent Comments</h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Rivas</span> on <a href="https://www.sbnewspaper.com/2012/07/20/quarterback-club-awards-scholarships/comment-page-1/#comment-1918207">Quarterback Club awards scholarships</a></li><li class="recentcomments"><span class="comment-author-link">Manuel Garcia</span> on <a href="https://www.sbnewspaper.com/2021/06/17/defenestration-of-the-sb-city-charter/comment-page-1/#comment-1918180">Defenestration of the SB City Charter</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://lrgvnews.com/2021/06/19/sbhs-cross-country-and-track-coach-hosts-fundraiser-for-athlete-san-benito-news/' rel='external nofollow ugc' class='url'>SBHS cross country and track coach hosts fundraiser for athlete – San Benito News &#8211; Lower RGV News</a></span> on <a href="https://www.sbnewspaper.com/2021/06/17/sbhs-cross-country-and-track-coach-hosts-fundraiser-for-athlete/comment-page-1/#comment-1918157">SBHS cross country and track coach hosts fundraiser for athlete</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://cancer.com.ng/a-fathers-day-story-a-story-of-hope-young-cancer-survivor-pursues-hollywood-dream-san-benito-news/' rel='external nofollow ugc' class='url'>A Father&#039;s Day Story – A Story of Hope Young cancer survivor pursues Hollywood dream - San Benito News - Nigeria Cancer Blog</a></span> on <a href="https://www.sbnewspaper.com/2021/06/17/a-fathers-day-story-a-story-of-hope-young-cancer-survivor-pursues-hollywood-dream/comment-page-1/#comment-1918156">A Father’s Day Story – A Story of Hope Young cancer survivor pursues Hollywood dream</a></li><li class="recentcomments"><span class="comment-author-link">Tal</span> on <a href="https://www.sbnewspaper.com/2021/06/17/a-fathers-day-story-a-story-of-hope-young-cancer-survivor-pursues-hollywood-dream/comment-page-1/#comment-1918151">A Father’s Day Story – A Story of Hope Young cancer survivor pursues Hollywood dream</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://lrgvnews.com/2021/06/18/hernandez-signs-with-bethany-college-to-play-football-san-benito-news/' rel='external nofollow ugc' class='url'>Hernandez signs with Bethany College to play football – San Benito News &#8211; Lower RGV News</a></span> on <a href="https://www.sbnewspaper.com/2021/06/17/hernandez-signs-with-bethany-college-to-play-football/comment-page-1/#comment-1918130">Hernandez signs with Bethany College to play football</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://www.worldcatholicnews.com/a-fathers-day-story-a-story-of-hope-young-cancer-survivor-pursues-hollywood-dream-san-benito-news/' rel='external nofollow ugc' class='url'>A Father’s Day Story – A Story of Hope Young cancer survivor pursues Hollywood dream – San Benito News - WORLD CATHOLIC NEWS</a></span> on <a href="https://www.sbnewspaper.com/2021/06/17/a-fathers-day-story-a-story-of-hope-young-cancer-survivor-pursues-hollywood-dream/comment-page-1/#comment-1918125">A Father’s Day Story – A Story of Hope Young cancer survivor pursues Hollywood dream</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://lrgvnews.com/2021/06/17/a-fathers-day-story-a-story-of-hope-young-cancer-survivor-pursues-hollywood-dream-san-benito-news/' rel='external nofollow ugc' class='url'>A Father’s Day Story – A Story of Hope Young cancer survivor pursues Hollywood dream – San Benito News &#8211; Lower RGV News</a></span> on <a href="https://www.sbnewspaper.com/2021/06/17/a-fathers-day-story-a-story-of-hope-young-cancer-survivor-pursues-hollywood-dream/comment-page-1/#comment-1918123">A Father’s Day Story – A Story of Hope Young cancer survivor pursues Hollywood dream</a></li></ul></div><!-- Featured Category Widget is not setup for this view. --><div id="super_rss_reader-2" class="sidebar-wrap clearfix widget_super_rss_reader"><h3>Port Isabel-South Padre Press</h3><!-- Start - Super RSS Reader v4.2-->
        <div class="super-rss-reader-widget"><div class="srr-main"><div class="srr-wrap srr-style-grey srr-vticker" data-visible="5" data-speed="4000" data-id="srr-tab-614"><div><div class="srr-item "><div class="srr-clearfix"><div class="srr-title"><a href="https://www.portisabelsouthpadre.com/2021/06/18/its-your-business-new-store-offers-laguna-madre-area-different-shopping-experience/" target="_blank" rel="nofollow noopener noreferrer" title="It’s Your Business: New store offers Laguna Madre area different shopping experience">It’s Your Business: New store offers Laguna Madre area different shopping experience</a></div><div class="srr-meta"><time class="srr-date" title="18 June 2021, 6:58 pm UTC">18 June 2021</time></div><a href="https://www.portisabelsouthpadre.com/2021/06/18/its-your-business-new-store-offers-laguna-madre-area-different-shopping-experience/" class="srr-thumb srr-thumb-align_left" style="width:64px;height:64px;"  target="_blank" rel="nofollow noopener noreferrer"><img src="https://www.portisabelsouthpadre.com/wp-content/uploads/2021/06/IMG_2694-300x225.jpg" alt="It’s Your Business: New store offers Laguna Madre area different shopping experience" align="left" /></a><div class="srr-summary srr-clearfix"><p>By RAY QUIROGA rayq@portisabelsouthpadre.com Area shoppers will be able to enjoy a different shopping experience beginning June 23 when an overstock liquidation retail store opens its doors in Port Isabel. Located at 1750 Hwy 100 in Port Isabel, within the Tarantino shopping center – at the same location where the former Bealls clothing store was … Continue reading <a href="https://www.portisabelsouthpadre.com/2021/06/18/its-your-business-new-store-offers-laguna-madre-area-different-shopping-experience/" title="Read more" target="_blank" rel="nofollow noopener noreferrer" class="srr-read-more">[...]</a></p></div></div></div><div class="srr-item srr-stripe"><div class="srr-clearfix"><div class="srr-title"><a href="https://www.portisabelsouthpadre.com/2021/06/18/narciso-chicho-martinez-the-man-and-his-music/" target="_blank" rel="nofollow noopener noreferrer" title="Narciso “Chicho” Martinez: The man and his music">Narciso “Chicho” Martinez: The man and his music</a></div><div class="srr-meta"><time class="srr-date" title="18 June 2021, 3:49 pm UTC">18 June 2021</time></div><a href="https://www.portisabelsouthpadre.com/2021/06/18/narciso-chicho-martinez-the-man-and-his-music/" class="srr-thumb srr-thumb-align_left" style="width:64px;height:64px;"  target="_blank" rel="nofollow noopener noreferrer"><img src="https://www.portisabelsouthpadre.com/wp-content/uploads/2021/06/Chicho-photo-104x300.jpg" alt="Narciso “Chicho” Martinez: The man and his music" align="left" /></a><div class="srr-summary srr-clearfix"><p>By RENE TORRES Special to the NEWS/PRESS Narciso “Chicho” Martinez was born with a gift bestowed to few.  He was a musician who could not read a note, but his innate love for music made him one of the most popular musicians in Spanish-speaking nations and communities here in the states.   In the 1930s, his … Continue reading <a href="https://www.portisabelsouthpadre.com/2021/06/18/narciso-chicho-martinez-the-man-and-his-music/" title="Read more" target="_blank" rel="nofollow noopener noreferrer" class="srr-read-more">[...]</a></p></div></div></div><div class="srr-item "><div class="srr-clearfix"><div class="srr-title"><a href="https://www.portisabelsouthpadre.com/2021/06/18/museums-movies-on-the-lighthouse-causeway-run-all-return/" target="_blank" rel="nofollow noopener noreferrer" title="Museums, movies on the Lighthouse, Causeway run all return">Museums, movies on the Lighthouse, Causeway run all return</a></div><div class="srr-meta"><time class="srr-date" title="18 June 2021, 3:44 pm UTC">18 June 2021</time></div><a href="https://www.portisabelsouthpadre.com/2021/06/18/museums-movies-on-the-lighthouse-causeway-run-all-return/" class="srr-thumb srr-thumb-align_left" style="width:64px;height:64px;"  target="_blank" rel="nofollow noopener noreferrer"><img src="https://www.portisabelsouthpadre.com/wp-content/uploads/2021/06/Museum-300x200.jpg" alt="Museums, movies on the Lighthouse, Causeway run all return" align="left" /></a><div class="srr-summary srr-clearfix"><p>By Gaige Davila editor@portisabelsouthpadre.com  While South Padre Island’s beaches and entertainment have fully opened to the public, quintessential Port Isabel events and facilities were slow to return, until now.  Port Isabel’s Historical Museum, housed in the former Champion Building on 317 E. Railroad Ave., reopened on June 9, after being closed for more than a … Continue reading <a href="https://www.portisabelsouthpadre.com/2021/06/18/museums-movies-on-the-lighthouse-causeway-run-all-return/" title="Read more" target="_blank" rel="nofollow noopener noreferrer" class="srr-read-more">[...]</a></p></div></div></div><div class="srr-item srr-stripe"><div class="srr-clearfix"><div class="srr-title"><a href="https://www.portisabelsouthpadre.com/2021/06/18/fishing-with-the-judge-hooks-big-turnout/" target="_blank" rel="nofollow noopener noreferrer" title="“Fishing with the Judge” hooks big turnout">“Fishing with the Judge” hooks big turnout</a></div><div class="srr-meta"><time class="srr-date" title="18 June 2021, 3:38 pm UTC">18 June 2021</time></div><a href="https://www.portisabelsouthpadre.com/2021/06/18/fishing-with-the-judge-hooks-big-turnout/" class="srr-thumb srr-thumb-align_left" style="width:64px;height:64px;"  target="_blank" rel="nofollow noopener noreferrer"><img src="https://www.portisabelsouthpadre.com/wp-content/uploads/2021/06/IMG_0410-300x200.jpg" alt="“Fishing with the Judge” hooks big turnout" align="left" /></a><div class="srr-summary srr-clearfix"><p>By Gaige Davila editor@portisabelsouthpadre.com  Harkening back to a Port Isabel of yesteryears, Cameron County Judge Benito Ochoa IV hosted the first annual “Fishing with the Judge” event this past Saturday. Hundreds of kids and parents took to the Pirate’s Landing Fishing Pier on June 12, rods and bait in hand, most of which provided by … Continue reading <a href="https://www.portisabelsouthpadre.com/2021/06/18/fishing-with-the-judge-hooks-big-turnout/" title="Read more" target="_blank" rel="nofollow noopener noreferrer" class="srr-read-more">[...]</a></p></div></div></div><div class="srr-item "><div class="srr-clearfix"><div class="srr-title"><a href="https://www.portisabelsouthpadre.com/2021/06/18/da-says-spacex-may-be-violating-texas-law/" target="_blank" rel="nofollow noopener noreferrer" title="DA says SpaceX may be violating Texas law">DA says SpaceX may be violating Texas law</a></div><div class="srr-meta"><time class="srr-date" title="18 June 2021, 3:19 pm UTC">18 June 2021</time></div><div class="srr-summary srr-clearfix"><p>By Gaige Davila editor@portisabelsouthpadre.com  The Cameron County District Attorney’s (DA) office thinks SpaceX may be breaking the law, after an unexpected detainment at the space company’s Boca Chica facility.  After a complaint by Save RGV, a Rio Grande Valley-based environmental justice group, staff from the DA’s office traveled to Boca Chica to investigate on Wednesday, … Continue reading <a href="https://www.portisabelsouthpadre.com/2021/06/18/da-says-spacex-may-be-violating-texas-law/" title="Read more" target="_blank" rel="nofollow noopener noreferrer" class="srr-read-more">[...]</a></p></div></div></div></div></div></div></div><!-- End - Super RSS Reader --></div><div id="iclw-2" class="sidebar-wrap clearfix widget_iclw"><h3>Directory</h3><ul><li><a target="_blank" href="http://cityofsanbenito.com/">City of San Benito</a></li><li><a target="_blank" href="http://www.sbcisd.net/">San Benito CISD</a></li><li><a target="_blank" href="http://www.startcenter.org/">START Center</a></li><li><a target="_blank" href="http://www.lppshelter.org/">La Posada Providencia</a></li><li><a target="_blank" href="http://www.sanbenitohistory.com/">San Benito Historical Society</a></li><li><a target="_blank" href="http://medtech.stisd.net/">South Texas Academy for Medical Professions</a></li><li><a target="_blank" href="http://www.ideapublicschools.org/Domain/63">San Benito IDEA Public Schools</a></li><li><a target="_blank" href="http://cityofriohondo.com/">City of Rio Hondo</a></li><li><a target="_blank" href="http://www.riohondoisd.net/">Rio Hondo ISD</a></li><li><a target="_blank" href="http://citylf.cloudaccess.net/en//">City of Los Fresnos</a></li><li><a target="_blank" href="http://www.lfcisd.net/site/default.aspx?PageID=1">Los Fresnos CISD</a></li><li><a target="_blank" href="http://www.fws.gov/refuges/profiles/index.cfm?id=21553">Laguna Atascosa National Wildlife Refuge</a></li><li><a target="_blank" href="http://www.co.cameron.tx.us/">Cameron County</a></li><li><a target="_blank" href="http://www.co.cameron.tx.us/sheriffs/sheriffsoffice.html">Cameron County Sheriff&#039;s Department</a></li><li><a target="_blank" href="http://www.co.cameron.tx.us/district_attorney/index.htm">Cameron County District Attorney&#039;s Office</a></li></ul></div>    
        
    
</div><!-- #sidebar1 -->        
        
    </div><!-- #content -->




<div id="footer" class="row">
    
                    <div class="footer-right">
                
                                    <div class="footer-menu-wrap flip">
                        <ul id="menu-main-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-165"><a href="https://www.sbnewspaper.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-161"><a href="https://www.sbnewspaper.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://www.sbnewspaper.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-163"><a title="Opinion" href="https://www.sbnewspaper.com/category/opinion/" class="dropdown-toggle" data-toggle="dropdown" data-submenu="1" data-depth="2" data-hover="dropdown" data-delay="0">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2078"><a href="https://www.sbnewspaper.com/category/opinion/letters/">Letters to the Editor</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2079"><a href="https://www.sbnewspaper.com/category/opinion/staff-columns/">Staff Columns</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164"><a href="https://www.sbnewspaper.com/category/gallery/">Gallery</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-186"><a href="https://www.sbnewspaper.com/?cat=11">Obituaries</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-158"><a title="E-Editions" href="http://www.etypeservices.com/San%20Benito%20NewsID78/" class="dropdown-toggle" data-toggle="dropdown" data-submenu="1" data-depth="2" data-hover="dropdown" data-delay="0">E-Editions</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2209"><a href="http://www.etypeservices.com/San%20Benito%20NewsID78/Default.aspx">San Benito News</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2081"><a href="http://www.etypeservices.com/South%20Padre%20ParadeID401/">South Padre Parade</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3859"><a href="http://www.etypeservices.com/San%20Benito%20NewsID78/Default.aspx">RGV Football Preview</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-250"><a href="http://www.etypeservices.com/San%20Benito%20NewsID78/Default.aspx">Winter Texan Guide</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9040"><a href="https://www.sbnewspaper.com/about/">Contact Us</a></li>
</ul>                    </div>
                            </div>
        
        <div class="copyright-developer">
                            <div id="copyright">
                    <p>&copy; 2021 San Benito News.</p>                </div>
            
                            <div id="developer">
                    <p>
                                                Made with <i class="fa fa-heart"></i> by <a href="https://www.graphene-theme.com/" rel="nofollow">Graphene Themes</a>.                    </p>

                                    </div>
                    </div>

                
    </div><!-- #footer -->


</div><!-- #container -->

	<div style="display:none">
	<div class="grofile-hash-map-70b8b7098e3f291b4907d36c0ca0481b">
	</div>
	</div>
		<a href="#" id="back-to-top" title="Back to top"><i class="fa fa-chevron-up"></i></a>
	
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.sbnewspaper.com\/2021\/06\/17\/school-board-passes-2021-2022-compensation-plan\/":168875};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/2021/06/17/school-board-passes-2021-2022-compensation-plan/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://www.sbnewspaper.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
            <script type="text/javascript">
            var sub = document.getElementById('submit');
            document.getElementById('recaptcha-submit-btn-area').appendChild (sub);
            document.getElementById('submit').tabIndex = 6;
            if ( typeof _recaptcha_wordpress_savedcomment != 'undefined') {
                document.getElementById('comment').value = 
                    _recaptcha_wordpress_savedcomment;
            }
            </script><link rel='stylesheet' id='slideshow-jquery-image-gallery-stylesheet_functional-css'  href='https://www.sbnewspaper.com/wp-content/plugins/slideshow-jquery-image-gallery/style/SlideshowPlugin/functional.css?ver=2.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='slideshow-jquery-image-gallery-stylesheet_style-light-css'  href='https://www.sbnewspaper.com/wp-content/plugins/slideshow-jquery-image-gallery/css/style-light.css?ver=2.3.1' type='text/css' media='all' />
<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.sbnewspaper.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.6' id='wp-polls-js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202125' id='grofiles-cards-js'></script>
<script type='text/javascript' id='wpgroho-js-extra'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=9.8.1' id='wpgroho-js'></script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/plugins/wp-gallery-custom-links/wp-gallery-custom-links.js?ver=1.1' id='wp-gallery-custom-links-js-js'></script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script type='text/javascript' id='wp_bannerize_frontend_js-js-extra'>
/* <![CDATA[ */
var wpBannerizeJavascriptLocalization = {"ajaxURL":"https:\/\/www.sbnewspaper.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/plugins/wp-bannerize/js/wpBannerizeFrontend.min.js?ver=3.1.6' id='wp_bannerize_frontend_js-js'></script>
<script type='text/javascript' id='slideshow-jquery-image-gallery-script-js-extra'>
/* <![CDATA[ */
var SlideshowPluginSettings_168865 = {"animation":"slide","slideSpeed":"1","descriptionSpeed":"0.4","intervalSpeed":"4","slidesPerView":"1","maxWidth":"0","aspectRatio":"3:1","height":"640","imageBehaviour":"natural","showDescription":"false","hideDescription":"true","preserveSlideshowDimensions":"false","enableResponsiveness":"true","play":"true","loop":"true","pauseOnHover":"true","controllable":"true","hideNavigationButtons":"false","showPagination":"true","hidePagination":"true","controlPanel":"true","hideControlPanel":"true","waitUntilLoaded":"true","showLoadingIcon":"true","random":"false","avoidFilter":"true"};
var slideshow_jquery_image_gallery_script_adminURL = "https:\/\/www.sbnewspaper.com\/wp-admin\/";
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/plugins/slideshow-jquery-image-gallery/js/min/all.frontend.min.js?ver=2.3.1' id='slideshow-jquery-image-gallery-script-js'></script>
<script async="async" type='text/javascript' src='https://www.sbnewspaper.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
<script type='text/javascript' id='milapfbwidgetscript-js-extra'>
/* <![CDATA[ */
var milapfbwidgetvars = {"app_id":"503595753002055","select_lng":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/plugins/facebook-pagelike-widget/fb.js?ver=1.0' id='milapfbwidgetscript-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sbnewspaper.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=9.8.1' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<script src='https://stats.wp.com/e-202125.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.8.1',blog:'47933013',post:'168875',tz:'-5',srv:'www.sbnewspaper.com'} ]);
	_stq.push([ 'clickTrackerInit', '47933013', '168875' ]);
</script>
</body>
</html>